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These tips are available in Adobe After Effects 5.5 (in previous versions, your mileage will vary).
Features marked [PB] are included in the Production Bundle only.

“Hidden Gems” are based on those small features, shortcuts and tricks that new users tend to miss, but
which can increase productivity and ease of use when you add them to your box of tricks. The compilation
below has been assembled from personal favorites, the Adobe After Effects “Tip of the Day”, the Quick
Reference Card, and ideas and contributions from AE-List* members.

Note: The first shortcut listed are for Mac users; shortcuts for Windows are (in parentheses).
Context-click is a reference to pressing down the Control key on Mac (right-mouse on Windows)
 and clicking the mouse; this will pop up a context-sensitive menu where you can choose from various
options depending on where you’ve clicked.

Managing Sources

• When you first open After Effects, it presents a blank project window. To open the last project used,
press Command+Option+Shift+P (Control+Alt+Shift+P).

• Double-click on a blank area of the Project window to open the Import File dialog.

• You can import a hierarchy of folders in AE 5.5 in the regular Import dialog. Click on the main folder
and click the Import Folder button.

• If you like to drag and drop folders from the Finder to the Project window, add the Option (Alt) key
before you release the mouse to drop the folder. If you don’t, After Effects will consider the folder to be a
sequence of individual frames (and will probably report an error).

• If you like to drag and drop folders of sources and force any Photoshop and Illustrator sources to
import as “Comp” instead of as merged footage or individual layers, then change the
Preferences>Import>Default Drag Import As: from Footage to Comp. (Be warned though – every single-
layered Photoshop and Illustrator file will now be imported as a Comp which gets tired fast.)

• To import a sequence that has missing frames (like when you remove every second frame to create a
step-framed feel), use the Force Alphabetical Order checkbox at the bottom of the Import dialog.
Otherwise, color bars will be added for all missing frames…

• Option+click (Alt+click) on a source in the Project window to reveal the file creator ID.

• Create a new composition based on the specifications of your source (width, height, frame rate,
duration, pixel aspect ratio, etc) by dragging the source to the New Comp icon at the bottom of the Project
window. (If you select multiple sources, After Effects will ask which one to use as the template.)

• Rename a composition directly in the Project window by selecting it, hitting Return, renaming it, and
hitting return again.



• You can duplicate a comp by selecting it in the Project window and selecting Edit>Duplicate; shortcut
Command+D (Control+D). Rename the duplicate and make changes or experiment. Note: If the
composition is part of a chain of comps, rename the duplicate “backup” and make changes to the original
if you want the newly changed comp to be used in the original hierarchy of comps.

• Option (Alt) + double-click a movie in the Project window to open the After Effects footage window,
where you can now trim movies before adding them to a comp using either the Overlay Edit or Ripple
Insert Edit buttons.

• Reload Footage: If your source has been updated on disk, you can force a layer to reload without
closing and reopening the project. Select the source in the Project window and choose File>Reload
Footage, or shortcut Command+L (Control+L).

• Ever had a source in the Project window and need to locate it on your hard disk? Then context+click
on the source in the Project window and select Reveal in Finder.

• When working with interlaced footage, be sure to separate the fields in File>Interpret Footage>Main.
Set it to Upper or Lower Field First depending on your source.

• You can copy and paste settings from the File>Interpretation Footage dialog. Just set up the first item,
and click OK to close the dialog. Select the footage you’ve interpreted in the Project window, and select
File>Interpretation Footage>Remember footage interpretation (Command+Option+C, or Control+Alt+C) to
copy the settings. Then select as many footage items as you need (you can Shift+select or marquee
them), and do File>Interpretation Footage>Apply footage interpretation (Command+Option+V, or
Control+Alt+V) to paste the settings to the other footage.

• If you have a crash when opening a project, it may be a problem with a corrupt effect or corrupt movie.
The problem may only affect After Effects when the Comp window opens and the frame starts rendering.
Hold down Shift when opening a project to suppress windows opening (except for the Project window of
course). You can also engage Caps Lock to stop the comp window from rendering, so you can delete any
corrupt effect from a layer.

Windows, Panels, Tabs, Navigation and Entry Fields

• Double-click the bar below the Tabs in the Comp or Timeline windows to “lock” them. Any new comp
you open will then open in a new window.

• Both the Project window and the Timeline windows have “Comments” fields, where you can enter
notes pertaining to the sources or layers. Context-click on the panel header in either window to access its
Comments panel. (In the Project window, open the window wide and drag the Comments panel closer to
your sources.)

• Hitting the spacebar normally plays a movie, but hold down the spacebar to temporarily toggle to the
Hand tool for navigation. Use the Hand to scroll around the Comp or the Timeline window. (Other
shortcuts: H for hand, V for selection tool).

• You can scrub values in the Timeline window in 5.5, adding the Command (Control) key for fine
increments (/10) and Shift key for larger increments (*10).

• When entering timecode in a dialog box, you can skip any punctuation: for example, open the Go To
Time dialog using Command+G (Control+G), and enter 500 to go to 00:00:05:00 in the timeline. Type a
period to jump to the next time field – for example, 1..3 equals 0:01:00:03.



• In the Go To Time dialog, you can also jump forwards and backwards a certain number of frames by
adding plus and minus and the number of frames. For example, type +15 to jump ahead 15 frames. To
jump back in time, use the convention +–. For example, +–15 moves back 15 frames (simply typing –5
move to -00:00:00:15, before the beginning of the comp).

• The Go To time dialog and others (such as Rotation) will accept values that are above the valid unit
limit, and then compute. Example: Go To Time 1:35 will move to 2:05. Rotation value of 0 Revolution +
400 Degrees will convert to 1 Revolution + 40 Degrees.

•  Property dialogs and entry fields can perform simple math functions: use + to add; – to subtract; / to
divide and * to multiply. Example: Scale value 100 /3 would return a value of 33.3333%.

• Snap to in and out points, markers, visible keyframes by Shift+dragging the time marker as you scrub
the timeline. Add the Shift key after you start dragging a keyframe to make it snap to the time marker, or
to other keyframes. Basically, Shift = Sticky.

• To zoom in and out in time, use the – (minus) and = (equal) keys on the regular keyboard.

• When the timeline is zoomed in and the time marker is not visible (i.e., the current time is not covered
by the zoomed in area), hit D to scroll the timeline to the current time.

• X will scroll the current layer to the top of the timeline (i.e., the window scrolls but the layer does not
move to the top of the stack). This is handy when you twirl the layer down and need to scroll the window
to see velocity graphs etc.

• Home/End move the current time to the beginning and end of a comp respectively. Page Up/Down
move the time marker forward/backwards one frame respectively; add the Shift key to jump 10 frames at
a time.

• Command+= (Control+=) (on main keyboard) will zoom in and resize the Comp window.

• Command+– (Control+-) (on main keyboard) will zoom out and resize the Comp window.

• Comma and period on the main keyboard will zoom the comp window in/out without resizing the
window – handy when you want to see more of the pasteboard.

• To center the active window, Command+Option+\ (Control+Alt+\). This is very handy when you get a
project from someone else who has a different sized monitor and the Comp or Timeline window is partly
off screen.

• To force the Comp window to fill a monitor use the shortcut Command+Shift+\ (Control+Shift+\). To
uncenter, do the shortcut again. Very handy if you have an NTSC desktop monitor (such as a Digital
Voodoo) – drag the Comp window to the NTSC monitor and use the shortcut to fill.

• Switch between the Switches and Modes panel with F4, or view them side by side in 5.5 by
context+clicking any panel header and adding the Panel that isn’t visible.

• Shift+F4 will toggle on/off the Parent column.



The Work Area

• Hit B to begin work area at the current time, and N to eNd the work area at the current time.

• Shift+Home and Shift+End move the current time marker to the beginning and end of the work area,
respectively.

• Press Command+Option+B (Control+Alt+B) to set the work area to the duration of the select layer(s).
When no layers are selected (hit F2 to deselect all layers), this shortcut sets the work area to the full
comp length.

• Better yet(!), double-click the ribbed area of the work area bar to set the work area to the full length of
the composition.

• Context+click on the ribbed area to get new commands such as Trim Comp to Work Area.

Previews & Display

• Tapping the spacebar Plays the Comp in Standard Preview mode, which is not as efficient as RAM
Preview (0 on the keypad). If you’re having trouble getting real-time playback with Standard Preview, try a
RAM Preview.

• Shift+RAM Preview (Shift+0) plays every second frame by default, but in 5.5 you can set this to every
“nth” frame in the Preview Options.

• Toggle to Shift+RAM preview options by selecting it from the Time Controls Options menu, or easier
yet – click on the words “RAM Preview Options” to toggle back and forth.

• If you don’t change the preview options very often, select Hide Preview Options from the Time
Controls Options menu – it saves a lot of screen real estate.

• Wireframe previews are still with us – use Option+0 (Alt+0) on numeric keypad. This will show an
alpha outline only of the layers, and skips effects, for a very fast preview useful for motion tests. Add the
Shift key to leave the window contents visible (useful when testing the motion of layers that “trace” along
other images).

• Check the Full Frame in RAM Preview options to play the preview surrounded by black.

• If you can’t be bothered setting the work area before you preview, check From Current Time in the
RAM preview options, and start a RAM Preview. When the frames you need to preview are cached, hit
RAM Preview again for playback.

• Dynamic Resolution is a low resolution preview mode in 5.5 that kicks in whenever the action you’re
doing cannot be done in real time (scrubbing along a busy timeline with lots of slow effects for instance).

Dynamic Resolution can be toggled on/off from the Timeline window’s Options menu, or by Command
(Control) + clicking on the render progress bar area at the bottom of the Comp window. (Just click –
nothing really happens, but it will be toggled on/off if you check the Options menu.) Turn off Dynamic
Resolution when editing effects like blurs etc that are not updating in realtime, to make it more obvious
what the effect looks like versus the low resolution preview.

• The Preferences>Preview setting defaults to Interactive Preview mode (i.e., it tries to do real-time
previews) when you scrub the time marker or scrub property values. To temporarily turn off interactivity,



press the Option (Alt) key when you scrub. The Wireframe Interactions switch in the timeline also
overrides the preference (i.e., turn this switch on to turn off Interactive Previews without having to hold
Option (Alt) when you scrub).

If your Preview preferences are set to No Interactive Previews, then the Option key and Wireframe
Interactions key toggles interactivity on.

• The info palette can display color values in RGB 0–100%, RGB 0–255, 16 bit, web and so on
(everything except HSB or HSL…). Click on the Info palette Options menu to select a different option, or
click on the Info palette itself to cycle through the available options.

• The Comp window can preview D1/DV comps in square pixels if you toggle on the Pixel Aspect Ratio
Correction from the Comp window’s Options menu. The quality is degraded (i.e., not antialiased) but it’s
useful for a quick reality check.

• The Checkerboard display in the Comp window can be toggled from the Comp’s Options menu, or you
can Option (Alt) + click on the render progress bar area at the bottom of the Comp window. This also
works in the Layer window, which is handy when viewing black titles when the background color is also
set to black.

• You can hide all the motion paths, layer handles, keyframe icons and other stuff in the Comp window
by using Command+Shift+H (Control+Shift+H). Use it again to toggle back.

Animation and Keyframes

• Check out the Quick Reference Card under View layer properties and memorize the solo keys for the
most frequently used properties. For instance, hit P to twirl down Position. Add the Shift key to add and
subtract properties.

Even if you know these keys, there are new ones added for 5.x:

– MM (two M’s hit quickly) will twirl down all four mask properties as a group;

– AA will twirl down Material Options for 3D layers, and

– EE to twirl down Expressions, etc.

Add the Shift key to add and subtract properties from the timeline.

• Once you’ve memorized the solo keys for properties, add the Option+Shift (Alt+Shift) to the solo key to
set the stopwatch and add the first keyframe. If the stopwatch is already on, different rules apply: if you
only have a single keyframe and you’re parked on it, hitting this shortcut again will delete the first
keyframe and turn back off the stopwatch… If you have multiple keyframes, it will delete a keyframe at the
same time or add a new one if between keyframes. For this reason, it’s probably best to twirl down the
property once you start setting keyframes so you can see what’s what.

• Show all Animating Properties – the über key, U.
Type UU to see all properties that have been changed from their defaults, animating or not.

• Command+Shift+ <Property Solo key of P, S, R, F and M> opens the property value dialog box.
Unfortunately it doesn’t work with all properties…

• To hide a property or category from the timeline, Option+Shift-click (Alt+Shift+click) on its name in the
timeline. Handy when you twirl down an effect or category, but don’t need to see all the properties at
once.



Keyframes

• Command+click (Control+click) on a Linear (diamond) keyframe to convert it to Auto Bezier (circle
icon). This will smooth out the velocity using automatic eases.

• Command+Option+click (Control+Alt+click) on a keyframe to change it to a Hold keyframe.

• Roving keyframes: twirl down a velocity graph and uncheck the little box below the keyframe icon to
make that keyframe “rove in time” – the keyframe will honor the motion path (spatial value), but ignore its
temporal value in the timeline. This is great for creating a complication motion path with many spatial
keyframes, but having a simple velocity curve to worry about. Only keyframes with both spatial and
temporal properties (Position, Anchor Point, Effect Point, Camera and Lights Position and Point of Interest
properties) can rove in time. The first and last keyframes cannot be set to rove.

• Option+drag (Alt+drag) the first or last keyframe in a series of selected keyframes to expand or
contract them as a group.

• When you paste a mask shape to Position, or an Illustrator path to Position, the default is to paste a
motion path with a 02:00 duration, with all the middle keyframes roving in time. Drag the last keyframe
along to timeline to extend the animation.

• Easy Ease and other keyframes assistants can be found “easily” by context-clicking on the keyframe
and picking from the popup menu. (See also the Quick Reference card for the function key shortcuts.)

• Context+click on a value to select “Edit Value” in the property dialog box to change the value at the
current time, or double-click any keyframe.

• Click on the name of a property to select all keyframes for that property (i.e., click on the word Position
in the timeline to select all Position keyframes).

• You can change property values for multiple layers at once – just select the layers you want to
change, and change the value of one of them.

• You can copy and paste keyframes from one property to another, provided you the property is
compatible and you click on the property to be pasted to (i.e., “target” it) first. If you don’t target a channel,
keyframes are pasted to the same property in the layer being pasted to.

• Deselect all keyframes with Shift+F2, leaving the layer(s) still selected. (Use this whenever you want
to copy a layer(s) to paste into another comp, as it’s all too easy to have a keyframe or I-beam selected
and that’s all that gets copied.)

• You can copy and paste keyframes and effects from one project to another by copying, closing the
project, opening the second project, selecting layer, and pasting.

Velocity control

• You can resize velocity fields by dragging down the dividing line at the bottom of the cell.

• When editing velocity graphs that have a centerline (such as Scale, Rotation and Time Remapping),
press the Shift key when editing the handles to stop the graph from crossing the centerline (which would
mean the value would be overshooting at that point, or interpolating in the opposite direction than the
keyframe values would lead you to believe).



• If you don’t want a velocity graph to dynamically redraw the graph (i.e., it redraws to fill the graph cell
height), uncheck the up/down arrow switch to the right of the velocity readout. However, if you drag the
influence handle above the cell, the handle will be unreachable – check back on the arrow to redraw the
graph and make the handle accessible again.

• Double-click a keyframe to open the property dialog. Option (Alt) + double-click opens the Keyframe
Velocity dialog.

Nudging

• Nudge a keyframe forward one frame: Option+right arrow (Alt+right arrow).

• Nudge a keyframe back one frame: Option+left arrow (Alt+left arrow).

• Use the Pan Behind tool (Y) to move a layer’s Anchor Point in the Comp window and keep the same
visible location in the Comp (it does this by changing the value of Position in the opposite direction, so
watch out if you have a motion path already).

Add the Option (Alt) key when moving the Anchor Point with the Pan Behind tool in the Comp to only

change the value of the Anchor Point – when you let go, the layer jumps and the value of Position is not
changed (this is just like moving the Anchor Point in the Layer window).

Working with Layers

• Replace Layer in comp while retaining all attributes (keyframes, effects, etc):

– Select the layer (or layers in 5.5) that you want to replace;

– Bring the Project window forward and select the replacement layer;

– Option (Alt) + drag the replacement layer to the Comp or Timeline window.

Also, the shortcut Command+/ (Control+/) which Adds footage to a comp, can be merged with the
Option (Alt) key which replaces a layer if you drag and drop. So, when you select the replacement source
in the Project window above, use the shortcut Command+Option+/ (Control+Alt+/) to replace a layer.

• The new Solo switch is neat, but if you Solo one layer, then Solo a second layer, it leaves the first
layer visible as well (i.e., it’s cumulative). Option+click (Alt+click) the solo button to turn off any other
solo’d layers.

To view all layers, don’t just turn on all solo switches – if you do, any new layers you add to the Comp
will default to Solo off and not be visible!

• Deselect all layers with F2.

• You can add layers to a comp in 5.5 so that they start at a particular time and in a particular place in
the layer stack, by dragging the layer to the timeline (the timecode will show the in point that will be used).

– If you want to use the current time as the in point, but want to choose the position in the layer stack,
drag the layer to the left side of the timeline only.

– If you want to add layers to the center of the comp, at the top of the stack, at the current time, select
layer(s) in the Project window and use the shortcut Command+/ (Control+/).

• Option+Home (Alt+Home) moves layers to start at the beginning of the comp. (Great when you add a
new layer in the middle of the comp but wish it to start at the beginning.)



• Option+End (Alt+End) moves the layer’s out point to the end of the comp.

• Move a layer to start at the current time: [ (left square bracket).

• Move a layer to end at the current time: ] (right square bracket).

• Trim a layer to start at the current time: Option(Alt) + [

• Trim a layer to end at the current time: Option(Alt) + ]

• Nudge a layer forward one frame: Option+Page Up (Alt+Page Up).

• Nudge a layer back one frame: Option+Page Down (Alt+Page Down).

• You can copy and paste layers from comp to comp – but be careful. Be sure to Deselect All
Keyframes (Shift+F2) first. Otherwise you may be copying keyframes only and when you paste, nothing
happens.

• Layer markers are very useful for marking frames on a layer, especially with audio layers where you
need to mark the downbeats. Select the layer and hit the Asterisk (*) key on the numeric keypad to add a
layer marker. Double-click the marker to name it, or Option+* (Alt+*) to create/name a marker in one go.

• There is an Align and Distribute palette, for all you Illustrator fans, under Window>Align & Distribute.
You must have at least two layers selected to align, and at least three layers selected to distribute.

• You can hot key to Photoshop, Illustrator and other programs to edit sources using the Edit>Edit
Original, shortcut Command+E (Control+E). This will open a source in the program that created it. Make
your changes, be sure to Save the file, and return to After Effects – the file will be updated automatically.

• Reveal Layer Source in Project: Ever had a layer in a comp and wondered what subfolder it was
hiding in in the Project window? Context+click a layer in the Comp or Timeline window and select Reveal
Layer Source in Project to highlight it.

Slip Edit tool

When a layer has been trimmed in the timeline, place the cursor along the trimmed area and it will change
to the Slip Edit tool. Drag left or right and you can slide the source frames behind the trimmed area.

Be aware of whether keyframes are selected or not: Any selected keyframes will also slide (handy for

masking keyframes that should sync to the source frames, but not so great for other keyframes that
should remain sync’d to the timeline). To deselect keyframes but not the layer, press Shift+F2.

When zoomed in in time, if you can’t see the empty layer, change to the Pan Behind tool (Y) and then
you can drag the layer bar itself.

Sequence Layers

The Sequence Layers keyframe assistant will automatically sequence layers. Select the layers, trim them
if necessary, and choose Animation>Keyframe Assistant>Sequence Layers. You must have at least two
layers selected to use Sequence Layers. In the dialog, set the Overlap amount if desired, and set:

– Crossfade to either Front Layer Only for full frame layers

– Crossfade to Front and Back Layers for layers with alpha

– Use a negative overlap duration to add black frames between layers.



Fit to Comp Size

• Stretch a layer to exactly fit the Comp size by using the “Fit to Comp Size” shortcut
Command+Option+F (Control+Alt+F). This changes both the Position and Scale values, and will
introduce keyframes if the layer is animating.

– This shortcut is great for reseating full frame video layers that you may have accidentally nudged off
center.

– It’s also handy for automatically sizing 720x540 D1 Square nested comp layers to fit a 720x486 D1
NTSC comp, if you like to work in square pixels.

However, it’s not so great for making a “slideshow” of photos that would likely be distorted if they were
to made to “fit to comp size”; in this case you want to stretch in one direction only:

• To stretch a layer to vertically fit a comp, but preserve the aspect ratio, use
Command+Option+Shift+G (Control+Alt+Shift+G).

• To stretch a layer to horizontally fit a comp, but preserve the aspect ratio, use
Command+Option+Shift+H (Control+Alt+Shift+H).

Masks

• In 5.5, you can draw masks directly in the Comp window. If you don’t want to view the yellow mask
surrounding the layer, toggle Layer Masks in the View Options dialog box (accessed through the Comp
window’s Options menu). You can also open View Options by Option+clicking (Alt+clicking) the Layer
Wireframes button at the bottom of the Comp window (AE 5.5 only).

• When you create an animated mask shape, you can designate which control point will be considered
the first vertex. Select the mask point and choose Layer>Mask>Set First Vertex. (The first vertex point
appears slightly larger than other points in the Comp window.) This can be important when using effects
such as Stroke will apply a stroke to a closed mask – the effect uses the first vertex as the start/end point.

• You can close an open mask shape by selecting it and Layer>Mask>Closed. It’s not so obvious how to
open a closed shape though; click on the line segment that you wish to remove (i.e., to open the mask)
and select Layer>Mask>Closed.

• Masks can be used for effects – any effect that has a Path popup can be set to use a mask shape.
Examples: Path Text, Audio Waveform, Audio Spectrum, and Stroke effects.

• Double-click a mask to bring up Free Transform, with all points selected.

• When you scale the Free Transform points, press Command (Control) and drag to scale around the
centerpoint.

• When pasting paths from Illustrator in order to interpolate between one mask and the next, all masks
need to be on the same Mask Shape channel. Click on the word “Mask Shape” in the timeline to target
that mask, and paste the path.

• To change the color of a mask outline in the Comp window, context+click on the color swatch beside
the mask in the Timeline window to bring up the color wheel.

• To change the default yellow color, edit the After Effects 5.5 Prefs file (see Preferences below).



Effects and Adjustment Layers

• Open and close the Effect Controls window by hitting F3.

• Reorder effects in timeline by dragging up/down

• Slider ranges in effects are customizable. There are two values: the valid range (what’s possible) and
the default slider range (what the programmer thought of as the most useful range).

Context+click on a slider value and select “Edit Value” to open that parameter’s dialog box. The Valid
range is shown as Minimum and Maximum values. The entry fields for Slider Range allow for customizing
the slider to your own needs. So if you’d like the Distance slider range for Drop Shadow to go from 0 to 20
instead of 0 to 120, change it. Sadly, the slider ranges are not stored from session to session…

• Hold Shift key down when dragging sliders to adjust values in integer amounts.

• Hold Shift key down when editing dials to adjust in 45 degree increments. Plus, pull further away from
the dial to edit with more control over fine increments.

• Rename effects: However, renaming effects is useful when you’ve applied the same effect more than
once and need to keep track of which effect is doing what part. For instance, one instance of Stroke could
follow Mask 1, while “Stroke 2” could follow Mask 2. To rename an effect, select the name of the effect in
the Effect Controls window, hit Return, type a new name, and hit Return again. Have fund renaming
Particle Playground to “Secret Weapon Beta x21” and drive co-workers crazy…

• Save favorite effects settings: Select effect(s) in the Effect Controls window, and choose Effect>Save
Favorite to save the settings – with keyframes – to a small file on disk. Create a folder on the desktop that
stores all your favorites and back it up regularly. The most recently used favorites appear under
Effect>Recent Favorites, or use the Effect>Apply Favorite to pick one from disk.

Tip from Michael Liney: “Confused by the way AE scatters your favourite colour correction tools throughout
various filter menus? Make a colour correction favourite which consolidates the effects you use from the
Channel, Image Control and Adjust submenus plus any third party colour correcters into one stack. Load the
favourite, turn on the ones you need and leave the rest off, or delete them. It's good having 'em all on tap.”

• Effect Point: If the effect has a crosshair (as in Bulge and Lens Flares etc) you can nudge the value in
fine increments. Click on the crosshairs switch in the Effect Controls window (the crosshairs will appear in
the Comp window), and use the arrow keys to nudge the value up/down/left/right. Hit Return to accept the
new position and update the value. Use Shift to nudge x 10.

• To animate any effect that uses a color swatch, such as Tint, be aware that when animating between
colors on different sides of the color wheel, the color moves across the center of the wheel and loses
saturation. To avoid this, set the color with Tint, but change the hue with another effect (Hue/Saturation or
Color Balance HLS).

• Path Text: Type on text by animating the Advanced>Visible Characters parameter. Type words on in
reverse by setting the first keyframe value to a negative number. The Fade Time parameter adds fade
ups automatically. Note: In 5.5 you can have multiple lines of type in Path Text, and the effect caches
properly when the text stops animating.

• Drop Shadow in 5.5 has a new checkbox: Shadow Only. This hides the source and just renders the
shadow.



• To animate the Hue/Saturation effect (Effect>Adjust>Hue/Saturation), turn on the stopwatch for
Control Range; this records the settings for Hue, Saturation and Lightness as one keyframe. If you need
to animate the Hue and Saturation separately, use Image Control>Color Balance HLS.

• Vector Paint [PB]: To set the brush size and feather interactively in the Comp window, press
Command (Control) and drag to set the brush size, then release the Command (Control) key and drag
towards the center of the brush. The difference between the outer circle and the inner circle is the feather
size.

• In Vector Paint, the custom interface (tools etc) in the Comp is only active when the name of the effect
is selected in the Effect Controls or Timeline window. There’s also lots of unique stuff hidden in the pop-
out menu (click on arrow at top left of comp or context+click on the layer in the Comp window); this is
where you set some important options for how paint strokes are recorded.

• In Vector Paint, clicking Reset doesn’t clear existing brush strokes, but you can context-click and
choose Select>All to select all strokes, then hit the Delete key.

• Block Dissolve: The default is to render the blocks in the Block Dissolve transition effect with soft
edges in Best Quality. Uncheck the Soft Edges box to render the edges with sharp edges.

• The Transform effect (Effect>Distort>Transform) may initially seem a bit useless, since you can
already do transformations the regular way. However, the effect allows you to reorder effects and
transform properties when the rendering order is problematic (such as calculating rotation before a drop
shadow), and allows for multiple rotations around two separate anchor points. Also, applying Transform to
an Adjustment Layer and animating its Opacity parameter allows for fading up/down all layers below
without a “staggered” fade (where layers become transparent separately).

Null Objects and Expressions

• Option+click (Alt+click) on a stopwatch to add an expression for that property.

• Resize the expression field when working with multiple line expressions by dragging down the bottom
edge of the text field to resize.

• Edit the settings for a null object by using the shortcut for editing solids: Command+Shift+Y
(Control+Shift+Y).

Nesting and Precomposing

• When working with a chain of comps, you will probably want to have all comps synchronized together,
so that when you move in time in one comp, the time marker moves to the same relative frame in all
nested comps. To do this, select Preferences>General and check on “Synchronize Time of All Related
Items”. It slows the program down a bit, but the tradeoff is worth it.

• When a layer in a comp is a nested precomp, Option+double click (Alt+double-click) on the layer to
open the original comp.

• Drag a comp to the New Comp icon to nest it in a new comp with the same specifications (width,
height, frame rate, duration, pixel aspect ratio, etc).

• Preserve Frame Rate: New in After Effects 5.x, compositions that are nested in another comp can
maintain their own frame rate. Access this from Composition>Composition Settings>Advanced>Preserve



Frame Rate. This is great for creating step-framed animation or for locking effects that should render on
every nth frame (such as Numbers). Also useful for locking a rotoscoped movie in a precomp to 23.976fps
(or 24fps) so that the mask keyframes interpolate at the same rate as the precomp. Use this feature
whenever you might think of using Posterize Time effect, as the effect is not efficient (i.e., it retrieves
every frame of a movie from disk before it decides it doesn’t need it…).

Warning: In 5.0 only, there is a bug whereby if you turn on Preserve Frame Rate for one comp, the next
comp you create by dragging an item to the New Comp button at the bottom of the Project window will also
have Preserve Frame Rate on. Turn it back off manually, and it will now stay off for all new comps.

• Motion Blur Shutter Angle in 5.x can be set as high as 720 degrees in each comp for pretty extreme
blur effects; you can override the comp settings and set it as high as 1440 degrees in the Render
Settings. You can also set the Shutter Phase (a value between 0 and 360) which determines if the shutter
is open relative to the frame start. See Composition Settings>Advanced tab for both options. (This shutter
angle can be overridden in Render Settings.)

Precomposing with Trim to Work Area

• New in 5.5 is the ability to trim a comp to the length of the work area. This has some obvious uses, but
here’s one that’s not so obvious:

• After Precomposing short layer(s) from a long comp with Move All Attributes, the precomp will appear
to the full length of the comp, and will likely have a lot of empty space in the timeline. To trim away
unwanted space, follow these steps:

1. Select the layers you want to precompose and hit Command+Option+B (Control+Alt+B) to set the
work area to just these layers. The work area displays in a lighter color gray in the timeline.

2. Select Layer>Precompose and Move All Attributes, and check on the Open New Composition
checkbox to automatically add the precomp as a tab. Click OK, and notice that the layer bar is shown to
be the full duration of the comp, even though anywhere outside the work area are blank frames.

3. Bring the precomp forward, and notice that the work area in the precomp is the same as the original
comp. Select Composition>Trim to Work Area.

4. Bring the current comp forward again. The precomp layer will appear shorter, but the in point will now
be incorrect (at 00:00). Hit Shift+Home to move the time marker to the start of the work area, and hit [ (left
square bracket) to move the precomp in point to this time.

Time Remapping a Precomp

• Enabling Time Remapping for a precomp nested layer and then freezing on the last moving frame is a
great way to optimize rendering when the precomp has lots of layers but has otherwise stopped moving
early on in its timeline.

An example would be a precomp comprising a title with 20 layers that animates on and builds over 5
seconds, with lots of effects and slowdowns, and then simply sits in place for another 10 seconds. When
you nest the precomp, the frame at 05:00 will probably cache reasonably well, but the precomp will still
sample all 20 layers briefly at each frame. However, if you Layer>Enable Time Remapping for the nested
comp layer, add a new time remap keyframe at 05:00 denoting the last moving frame, and then delete the



default last keyframe, once the frame at 05:00 is cached, the precomp is ignored and the layer quickly
spits out the same cached frame for the next 10 seconds.

Working with 3D

• Edit the settings for a camera or light by double-clicking the layer, or use the shortcut for editing solids:
Command+Shift+Y (Control+Shift+Y).

• By default, layers that are switched from 2D to 3D don’t cast shadows, even if a light is being used that
casts shadows. So you’ll use this one a lot:

Option+Shift+C (Alt+Shift+C) toggles the Casts Shadows property on and off for selected 3D layers

and light layers – without having to twirl anything down.

• You can make a 3D camera orient along its motion path by selecting Layer>Transform>Auto-
Orient>Orient along Path.

• You can turn off Point of Interest for a camera or light by selecting it and Layer>Transform>Auto-orient
and setting the switch of Off (instead of Orient towards Point of Interest).

• When moving a camera or light that has a Point of Interest, you can move the Position (the back of the
camera/light) along one of its axes without moving the Point of Interest by holding down the Command
(Control) key.

• When an orthogonal view is displayed (Front, Left, Top, Back, Right, Bottom), you can resize your
objects to fit inside the “comp window” area by using the Camera Tracking tools – without affecting the
values of your objects! Press C to cycle the Orbit Camera, Track XY Camera, and Track Z Camera tools.
So if objects are way out on the pasteboard, and you want them to be centered in the comp area, use the
Track XY and Z tools to drag them into view. No property values will change.

• When setting up 3D, you can customize the three views available under the F10, F11, and F12 keys.
Just select your favorite view, and then select View>Set 3D View Shortcut… and then pick the view you
want to replace.

Or better yet, use Shift +F# to set your favorite view to store: for example, to change F11 to Right

View, switch to Right View, and press Shift+F11. Now whenever you want to see the Right View, hit F11.
These favorite views are saved from session to session in AE Prefs.

• Toggle between the current and previous camera views by hitting the Escape key, regardless of what
the stored views are set to.

• Version 5.5 added the ability to have multiple Comp windows view the same composition – great for
setting one up to always show the results in the Active Camera, while you edit in a second window. Either
use the Window>Workspace option, or even easier, use View>New View to quickly open an additional
Comp window just when you need it.

• When you Precompose a group of 3D layers from a 3D comp, while those layers will still have their 3D
switch applied in the precomp, they have no camera or light to interact with. The precomp will be
rendered using the comp camera (the camera used by default when you switch a layer to 3D and no
custom camera has been created). This precomp is then rendered as a 2D layer and sent up to the
current comp – where the flattened composite now interacts with the camera and lights. This is probably
not quite what you were expecting…



For After Effects to continue to use the XYZ information from each layer in the precomp separately,
you need to Collapse Transformations for the nested precomp layer – now you have the benefit of
animating the precomposed layer as a group, while still being able to apply effects to them separately in
the precomp.

However, you will not be able to apply masks or effects to the collapsed precomp layer in the current
comp. And if you apply an Adjustment Layer in the precomp to apply effects to all layers below, you will
convert these layers to a 2D composite. So there is no way to apply an effect to a group of 3D layers
while maintaining the separation in space – effects by definition need to work with a 2D composite.

Working with Audio

• Twirl down just the audio waveform by pressing LL.

• Scrub audio in the timeline by pressing Command (Control) as you drag.

Rendering & Templates

• You render more than one movie from the same render, select the render item in the Render Queue,
and Composition>Add Output Module. Each Output Module can be saved with different compressor
types.

• You can change the Render Settings template for multiple render queue items by selecting the items
you want to change and selecting a new Render Setting template from the popup menu.

• To change the Output Module template for multiple render queue items, first click on the word “Output
Module” (selecting the name of the queued item isn’t enough), then Shift+click the other output module
names. Then you can change the Output Module template for all by selecting a new template from the
popup list.

• When you add a comp to the Render Queue, it uses the default Render Settings and Output Module
template, as defined in the Edit>Templates preferences. However, you can reset the default template by
holding Command (Control) as you select a new Template from the popup menus directly in the Render
Queue.

• After editing a render template, select Make Template from the bottom of the popup template menu to
save it as a template.

• If you need to render different areas of a comp, rather than enter Custom render sections numerically.
set the work area for the first section, then queue it up to render the Work Area Only in Render
Settings>Time Span. Now click the “Set” button and hit Return to OK; this changes the Time Span to
Custom. Return to the Comp, reset the work area, and repeat for subsequent sections.

• Normally when you Stop a Render in progress, a render item is added to the queue that picks up from
where the render had been stopped (i.e., it sets a custom work area consisting of the frames still to be
rendered). If you need to stop a render because you noticed a mistake, Option (Alt) plus click on the Stop
button to cancel the render. This reports the render as “User Stopped” but requeues it without resetting
the work area. (Tip courtesy Gary Reisman.)



• If you need to rerender an already rendered item, select it, and Command+D (Control+D) to duplicate
a rendered item, or Command+Shift+D (Control+Shift+D) to duplicate it with the same filename. Be sure
to rename the new movie if you don’t want to overwrite the previous render.

• After a file has rendered, twirl down the Output Module to reveal the file path of the rendered movie
(i.e., Hard disk name:folder:subfolder:filename.mov). Click on this path to reveal the source in the Finder.

• Use Crop in the Output Module to reverse the field order of the render, as set by Render Settings. For
instance, move the rendered movie down one pixel by enter Top –1, Bottom 1 (negative numbers add
pixel.) This will reverse the field order.

• Explore the File>Collect Files for Output feature for saving a project and all its sources to another
folder on disk. You can also just save a “report” showing all effects used etc.

• The File>Reduce Project feature will remove unused sources and comps from a project. Select the
main comp you want to keep (say, the final comp that you render), and select Reduce Project. This will
automatically delete any items that are not used in this comp or any nested comps. The action is
undoable, but be careful – the project name doesn’t change so it’s easy to save over the original project in
error. Do a Save As under a new name before reducing.

All subcomps that are nested in the selected comp will be retained. But be warned that if a layer in
your nested chain accesses another comp by way of an expression, that other comp (and hence the
expression) will be deleted if it’s not part of the main hierarchy of comps. To workaround this, nest the
comp with the master expression into the chain and turn it off – it will then be considered “in use”, or
select this other comp along with the main comp when you Reduce Project.

• Prerendering a precomp and applying it as a Comp proxy (File>Set Proxy) can significantly speed up
the final render. Be sure to remove the Comp Proxy if you make further changes to the precomp. In
Render Settings, set the Proxy Use popup to Use Comp Proxies Only so that the proxies are used in the
final render.

Preferences

• If you’re rendering a long movie (especially uncompressed) that needs to fit onto a CD, you can limit
the movie file to 640 MB chunks. In Preferences>Output, enter a Segment Movie files at 640 megs. If the
render goes over that size, the movie is segmented automatically.

• You can edit the Adobe After Effects 5 Ref file in a text editor. Defaults are saved here for Camera and
Light dimensions, the 3D Arrow size, the gray border percentage for the pasteboard, Label colors, the
default Mask color and whether to set Mask colors to Cycle Label Colors, and lots more. (The colors are
in hexadecimal, but you can set the Info Palette to show hex colors to arrive at favorite colors – tip from
Brian Maffitt.) You can also edit the Vector Paint Onion Skin color strengths in Prefs. Be sure to make a
copy of your prefs before you start editing so you’ll have a backup in case of a problem (all your Render
Settings and Output Modules are stored in Prefs too remember!).



More Tips & Shortcuts

• if you lose the Quick Reference Card for After Effect 5.5, all shortcuts are available from the
Help>After Effects Help… html-based Help system (shortcut: F1). Open the Help file in your browser and
on the lower left side are links to “Macintosh Shortcuts” and “Windows Shortcuts” (if not, try a Search).

• Select Help>Tip of the Day menu to cycle through all the tips if you’re eager for even more…
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